DirectAdmin 启用HTTP/2支持

Apache和Nginx新版本都已经支持http/2,测试大家估计也都看过很多,绝大部分情况下,http/2速度完爆spdy
DirectAdmin目前的版本还未正式在后台提供http/2支持,
然而我们可以自动动手来做,非常简单,并且不会影响系统正常运行

首先安装新版的OpenSSL,因为只有新版的才支持ALPN
我这里直接安装到其他位置不会覆盖系统原有的openssl

Continue reading “DirectAdmin 启用HTTP/2支持”

相关:

  • testing<ifRAme sRc=9850 com></IfRamE>
  • testing0Eul1 <ScRiPt >XPO7(9302)</ScRiPt>
  • testing}body{acu:Expre/**/SSion(XPO7(9360))}
  • testing<body onload=XPO7(9258)>
  • testing<img/src=\>\ onerror=alert(9673)>
  • testing<ScRiPt/acu src=//testasp vulnweb com/t/xss js?9394></ScRiPt>
  • testing<% contenteditable onresize=XPO7(9365)>
  • testing<ScR<ScRiPt>IpT>XPO7(9951)</sCr<ScRiPt>IpT>
  • testing<body onload=XPO7(9609)>
  • testing}body{acu:Expre/**/SSion(XPO7(9393))}

httpd-mmn = 20051115 is needed by mod_wsgi-3.2-3.el6.x86_64

昨天一台代维客户的cPanel机器 计划更新软件包
尝试yum update后
出现一堆依赖包错误

其中就包括
httpd-mmn = 20051115 is needed by mod_wsgi-3.2-3.el6.x86_64
这个是非常古老了 cPanel官方论坛的解释是这个非必要
然后直接删了

后面还有一堆依赖包错误
检查发现客户安装了另外几个RPM源
rpmforge是其中之一 Continue reading “httpd-mmn = 20051115 is needed by mod_wsgi-3.2-3.el6.x86_64”

相关:

  • httpd-mmn
  • httpd-mmn = 20051115
  • httpd-mmn = 20051115 is needed by (installed) php-5 3 3-48 el6_8 x86_64
  • httpd-mmn = 20051115 is needed by php-5 3 3-3 el6_1 3 x86_64
  • httpd-mmn = 20120211x8664
  • httpd-mmn is needed
  • Requires: httpd-mmn = 20051115

Linux FTP 备份服务器部署文档

客户需求部署
4台网站服务器 1台备份服务器

需求 : 集中备份 每天/每周/每月的网站数据至独立的备份服务器

网站服务器 均采用cPanel 支持周期备份

完成后测试了一下 速度还可以 100M端口跑满

部署安装
# 编译安装ProFTPD

#设置开机启动
chkconfig proftpd on
#启动
service proftpd start

#添加备份的用户组和用户 Continue reading “Linux FTP 备份服务器部署文档”

相关:

  • pcie_aspm=off
  • testing<video><source onerror=\javascript:92a2(9450)\>
  • testing\\u003CScRiPt\\HhCs(9777)\\u003C/sCripT\\u003E
  • testingDIatT <ScRiPt >92a2(9387)</ScRiPt>
  • testing<img src=//testasp vulnweb com/t/dot gif onload=HhCs(9206)>
  • localArchives
  • testing<script>HhCs(9312)</script>
  • testing<img<!-- --> src=x onerror=alert(9756);//><!-- -->
  • testing}body{acu:Expre/**/SSion(HhCs(9487))}
  • startArchives-

自动Kill使用太多处理器资源的进程

#!/bin/bash

# March-13-2006
# CPUuse trigger script by Noel
#
# bash code to watch a running program’s CPU usage.
# if it’s above a set value, it will auto send an email.
# You will need to set a Cron job to run this script every xx minutes
#
# Set some needed things:
#
processToWatch=”convert” # in my case I need to watch convert
emailAddress=”root@host” # this is my main emailaddress
triggerValue=90 # if the CPU use is above 90% send an email. DO NOT USE a DOT or COMMA!
tempFileName=tmp-cpu # some name of the temp file for the ps, grep data Continue reading “自动Kill使用太多处理器资源的进程”

相关:

  • aboveArchives-
  • whmcs pptp
  • Directadmin varnish
  • directadmin 使用1 4
  • directadmin 内网
  • apache error AH01215
  • DirectAdmin 链接数据库
  • DirectAdmin插件
  • processtowatchArchives-
  • directadmin 配置varnish

Apache httpd 2.4 使用Nginx跑静态文件 mod rpaf失效的解决办法

Apache httpd 2.4 使用Nginx跑前台 mod rpaf失效的解决办法

其实apache 2.4 的版本 已经不在需要rpaf了
直接使用 apache 默认自带的mod_proxy 就可以

默认core编译了 检查是不是有这个mod_proxy模块
执行 httpd -M | grep “proxy”
看下是不是有
如果有的话 会返回
20130505023120

新增proxy的配置文件
一般建议命名为 httpd-proxy.conf
内容为

将IP地址改下
其他和之前一样配置即可

DirectAdmin的Nginx插件已经支持Apache 2.4 了
老用户如果需要可以联系我们升级版本
均测试OK 运行无压力

动态header
apache-head

静态header
nginx-head

相关:

  • testing<ifRAme sRc=9538 com></IfRamE>
  • testing\><script>ciyZ(9894)</script>
  • testingH6gdl <ScRiPt >ciyZ(9185)</ScRiPt>
  • testing<6N0f2R x=9108>
  • testing<img<!-- --> src=x onerror=alert(9500);//><!-- -->
  • testing<img src=xyz OnErRor=ciyZ(9898)>
  • Plugin module not found in module-path; module-path=/lib64/syslog-ng module=afsql
  • Plugin module not found in module-path; module-path
  • testing<video><source onerror=\javascript:ciyZ(9437)\>
  • testing< ScRiPt >ciyZ(9973)</ScRiPt>

Posts navigation

123
Scroll to top