httpd-mmn = 20051115 is needed by mod_wsgi-3.2-3.el6.x86_64

昨天一台代维客户的cPanel机器 计划更新软件包
尝试yum update
出现一堆依赖包错误

其中就包括
httpd-mmn = 20051115 is needed by mod_wsgi-3.2-3.el6.x86_64
这个是非常古老了 cPanel官方论坛的解释是这个非必要
然后直接删了

后面还有一堆依赖包错误
检查发现客户安装了另外几个RPM源
rpmforge是其中之一
尝试使用 yum update –disablerepo=rpmforge 更新
检查通过 代表是这个源导致的问题
yum remove rpmforge-release

在更新 OK了

其实代维的机器最不能提供ROOT
客户会进行各种导致 导致最后出现一堆问题
如果出现系统崩溃 就悲剧了

cPanel官方的讨论
Hello

The primary RPM causing the problem here appears to be:

mod_wsgi-3.2-3.el6.x86_64

This is not a standard RPM that is installed on cPanel servers. Is it required on your system for a custom application? If not, you may want to consider removing the “mod_wsgi” package from your system.

Thank you.
意思是非官方标准RPM需求 是不是有定制应用安装的

然后出现问题的用户 检查了下
root@h2 [~]# yum history list mod_wsgi
Loaded plugins: fastestmirror
ID | Login user | Date and time | Action(s) | Altered
——————————————————————————-
140 | <*****> | 2013-05-14 14:40 | Erase | 1
1 | System | 2011-08-07 14:42 | Install | 394
history list

相关:

  • httpd-mmn
  • weighj5o
  • Requires: httpd-mmn = 20051115
  • httpd-mmn is needed
  • httpd-mmn = 20120211x8664
  • httpd-mmn = 20051115 is needed by php-5 3 3-3 el6_1 3 x86_64
  • httpd-mmn = 20051115 is needed by (installed) php-5 3 3-49 el6 x86_64
  • httpd-mmn = 20051115 is needed by (installed) php-5 3 3-48 el6_8 x86_64
  • httpd-mmn = 20051115
  • hornzoq

发表评论

电子邮件地址不会被公开。 必填项已用*标注

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Scroll to top