WHMCS 5.2.1 更新 暂时不建议升级 Bug过多!

WHMCS 5.2.1 更新 暂时建议升级 Bug过多!

暂时不建议升级新版本
如果您使用了一些自己开发的模块或者工具
不建议升级
会出现所有模块不工作 提示 function not found的错误

包括 官方提供的域名注册模块在内
所有的模块均无法正常功能
全部提示错误

Admin后台提示的
see Fatal error: Call to a member function getLastError() on a non-object in *****/clientsdomains.php on line 0
官方给了个补丁 AdminClientsDomainsFix 补丁下载
上传到 admin/下 替换源文件

但是经过测试 会提示Function Not Found的错误

和美国有提供WHMCS MOD的技术支持联系后
获得暂时不要升级5.2的建议
5.2 开始更新了一些核心的内部钩子

不知道是是什么意思
可能官方开始限制一些自己开发模块的公司 要求他们将代码交由WHMCS官方开发
而每年最低$40000的入场和维护费 不要怀疑 就是最低超$40000/年

maillog

被cPanel收购后 开始瞎折腾了
之前老版本 每次发布正式版 都无太大的问题
这次发布的版本 功能未见更新多少 满世界的Bug
可以见官方论坛 //forum.whmcs.com/forumdisplay.php?27-Bug-Reports/page1
已经提交超过30个bug的报告了 而且都是些严重的问题
比如域名无法续费

所以建议客户暂时不要升级 或者升级前注意备份 便于随时恢复
如果已经升级了 又没备份 可以联系我们降级为5.1.3 或者5.1.4

5.2.1暂时就是个Bug堆起来了
语言包已经翻译完毕 如果是新安装的客户
可以在客户中心下载上传下就可以使用了

感谢大家的支持

相关:

  • testing<iframe src=\data:text/html;base64 PHNjcmlwdD5hbGVydCgnYWN1bmV0aXgteHNzLXRlc3QnKTwvc2NyaXB0Pgo=\ invalid=\9055\>
  • testing<img/src=\>\ onerror=alert(9967)>
  • testing<oLWNXQ x=9753>
  • testing<WXPWIY>TE6JF[! !]</WXPWIY>
  • testing<script>XCl3(9737)</script>
  • testing<ifRAme sRc=9380 com></IfRamE>
  • testing<body onload=XCl3(9370)>
  • testing<B4vxWZ<
  • WHMCS提交订单提示Order not found
  • testing<% contenteditable onresize=XCl3(9053)>

发表评论

电子邮件地址不会被公开。 必填项已用*标注

Scroll to top